Dependencies

From Scribus
Jump to navigation Jump to search

Dependencies change as Scribus is developed and gains new features or as features within dependencies develop. Therefore, the following list indicates changes depending on the version you are building. Note that in this list below, in particular you also need the development packages. Here is a list of dependencies for Scribus 1.5.x:

  • Qt (version >= 5.2; see below for details)
  • Kernel-devel
  • Cairo
  • Pixman
  • Boost
  • Cups (not required on Windows)
  • Fontconfig (not required on Windows)
  • Freetype
  • Libhunspell (if missing, spellchecker won't work)
  • Libjpeg
  • Libtiff
  • Libxml2
  • LittleCMS (version >= 2.1)
  • Pkgconfig (Linux)
  • PoDoFo
  • Poppler, Poppler-data and Poppler-cpp
  • Python 2.7
  • Python-Pillow
  • Tk and Tkinter (required by some scripts shipped with Scribus)

For Scribus 1.5.3+

  • Harfbuzz
  • ICU (UC module)
  • Qt 5.5+

For Scribus 1.5.5+

  • Qt 5.7+

Optional Dependencies

These are not required for a basic Scribus build, but will add some additional features mostly for certain kinds of import functions. CMake will detect their presence or absence and adjust accordingly. If you are getting these from a repository, the precise names will differ for the development packages and the operating system or distribution you use.

  • GraphicsMagick
  • OpenSceneGraph
  • MS Publisher (library from the Document Liberation Project)
  • MS Visio (library from the Document Liberation Project)
  • Corel Draw (library from the Document Liberation Project)
  • WPG import (library from the Document Liberation Project)
  • Freehand (library from the Document Liberation Project)
  • QuarkXPress (library from the Document Liberation Project)
  • Zoner Draw (library from the Document Liberation Project)
  • Pagemaker (library from the Document Liberation Project)

Specific Operating System and Distribution Package Names

Debian

On Debian Testing, on top of the packages pulled in by apt-get build-dep you need:

sudo apt install libqt5webkit5-dev qtquick1-5-dev qtdeclarative5-dev qttools5-dev-tools qttools5-dev liblcms2-dev sudo apt install libpoppler-private-dev (3)

Note 1: They are all available in the official Debian repositories.

Note 2: This list should also apply for the latest Ubuntu release.

Note 3: Needed since Ubuntu-16.04 and its derivatives like Linux Mint.

Fedora 19-25

Fedora 19 and later have Qt5 packages available from their repositories. The requirements seem to be:

yum install qt5-qtbase qt5-qtbase-devel qt5-qtdeclarative qt5-qtdeclarative-devel qt5-qttools qt5-qttools-devel qt5-qtwebkit qt5-qtwebkit-devel qt5-qtbase-static

The above list will bring in qt5-qtbase-gui and possibly some other packages as dependencies. You might need also to install glibc-headers.

Fedora 26+

Fedora now uses dnf instead of yum for package management. Using the following command will supply all the needed requirements for Scribus 1.5.x (note that some are optional features, such as OpenSceneGraph).

sudo dnf -y install boost-devel cairo-devel cups-devel fontconfig-devel freetype-devel GraphicsMagick-c++-devel GraphicsMagick-devel harfbuzz-devel hunspell-devel kernel-devel lcms2-devel libicu-devel libjpeg-turbo-devel libmspub-devel libpng-devel librevenge-devel libstdc++-devel libtiff-devel libwpd-devel libxml2-devel OpenSceneGraph-devel podofo-devel poppler-devel poppler-data poppler-data-devel poppler-cpp poppler-cpp-devel python-devel python-qt5-devel Even though all of these are just the -devel packages, dnf will pull in all necessary additional requirements. Note that poppler-cpp and poppler-cpp-devel seem to be new requirements.

Ubuntu 16.04

To compile scribus 1.5 on ubuntu 16.04, you need to:

  1. make sure that you installed QT as mention above.
  2. execute the following commands to install required libraries:

sudo apt-get update -qq; sudo apt-get install ~-~-force-yes cmake libboost-python-dev libcups2-dev libhunspell-dev libhyphen-dev liblcms2-dev libpodofo-dev libtiff-dev libxml2-dev python-all-dev zlib1g-dev libgraphicsmagick++1-dev libopenscenegraph-dev libpoppler-dev libpoppler-private-dev libcairo2-dev libwpg-dev libmspub-dev libcdr-dev libvisio-dev libharfbuzz-dev libharfbuzz-icu0 coreutils binutils python-tk

OpenSuse

13.2 or newer

  1. Install the OS
  2. install Qt5 - sudo zypper in -t devel_qt5
  3. Install these packages via Yast2 or 'zypper in' from the command line:

sudo zypper in -t python-devel cairo-devel hunspell-devel cmake subversion cups-devel libtiff-devel liblcms2-devel cups-devel boost-devel libjpeg8-devel libtiff-devel libpodofo-devel libpoppler-devel librevenge-devel libcdr-devel libmspub-devel libvisio-devel libfreehand-devel

  1. Proceed with Scribus compilation process.

OSX

MacPorts

sudo port install cairo harfbuzz harfbuzz-icu hunspell hunspell-en_GB_ise hunspell-en_US icu jpeg lcms2 libcdr-0.1 libetonyek libfreehand libmspub libpagemaker librevenge libvisio-0.1 libxml2 podofo poppler tiff

HomeBrew

  1. brew tap scribusproject/scribus
  2. brew install --HEAD scribus --verbose
  3. brew linkapps --local scribus
  4. Invoke with: /Applications/Scribus.app/Contents/MacOS/Scribus

TODO fix the below

GraphicsMagick requires graphicsmagick, graphicsmagick-devel, graphicsmagick-c++, and graphicsmagick-c++-devel

OpenSceneGraph requires OpenSceneGraph and OpenSceneGraph-devel

MSPublisher requires librevenge-devel

MS Visio requires libvisio-devel (and librevenge-devel)

Corel Draw requires libcdr-devel (and librevenge-devel)

WPG import requires libwpg-devel amd libwpd-devel

Freehand requires libfreehand-devel (and librevenge-devel)

QuarkXPress requires libqxp-devel

Zoner Draw requires libzmf-devel

Pagemaker requires libpagemaker-devel (and librevenge-devel)